aboutsummaryrefslogtreecommitdiff
path: root/master/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'master/CMakeLists.txt')
-rw-r--r--master/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/master/CMakeLists.txt b/master/CMakeLists.txt
new file mode 100644
index 0000000..664d458
--- /dev/null
+++ b/master/CMakeLists.txt
@@ -0,0 +1,8 @@
+# For more information about build system see
+# https://docs.espressif.com/projects/esp-idf/en/latest/api-guides/build-system.html
+# The following five lines of boilerplate have to be in your project's
+# CMakeLists in this exact order for cmake to work correctly
+cmake_minimum_required(VERSION 3.16)
+
+include($ENV{IDF_PATH}/tools/cmake/project.cmake)
+project(main)